TMC - Command & Control and Telemetry

Incident Report for TMC

Resolved

AWS has confirmed that the issue was resolved at 8:12AM and we have seen no further impact. All services are operating as expected.
Posted Jul 24, 2026 - 09:09 EDT

Identified

Our investigation has identified an ongoing global AWS network degradation as the likely source of the issue. A support ticket has been opened with AWS. We will provide additional updates as more information becomes available.
Posted Jul 24, 2026 - 07:40 EDT

Investigating

At 6:57 AM EDT, we detected a drop in Command & Control success rates and telemetry delays in the TMC Production environment. Our engineers are actively investigating the cause of this incident and will provide additional details as they become available.
Posted Jul 24, 2026 - 07:29 EDT
This incident affected: Telemetry (FTCP, Native) and Command & Control (FTCP, Native).